add files needed to build RTD
3 files changed, 26 insertions(+), 1 deletions(-)

M .build.yml
A => .readthedocs.yml
A => docs/requirements.txt
M .build.yml +1 -1
@@ 43,7 43,7 @@ tasks:
 
     poetry -q update
 
-    poetry -q install
+    poetry install
 
     poetry run coverage run --source=sqlalchemy_querybuilder -m pytest
 

          
A => .readthedocs.yml +20 -0
@@ 0,0 1,20 @@ 
+# .readthedocs.yml
+# Read the Docs configuration file
+# See https://docs.readthedocs.io/en/stable/config-file/v2.html for details
+
+# Required
+version: 2
+
+# Build documentation with MkDocs
+mkdocs:
+  configuration: mkdocs.yml
+
+# Optionally build your docs in additional formats such as PDF
+formats:
+  - pdf
+
+# Optionally set the version of Python and requirements required to build your docs
+python:
+  version: 3.7
+  install:
+    - requirements: docs/requirements.txt

          
A => docs/requirements.txt +5 -0
@@ 0,0 1,5 @@ 
+markdown-include==0.6.0 \
+    --hash=sha256:6f5d680e36f7780c7f0f61dca53ca581bd50d1b56137ddcd6353efafa0c3e4a2
+mkdocs==1.1.2 \
+    --hash=sha256:096f52ff52c02c7e90332d2e53da862fde5c062086e1b5356a6e392d5d60f5e9 \
+    --hash=sha256:f0b61e5402b99d7789efa032c7a74c90a20220a9c81749da06dbfbcbd52ffb39