common: properly export CW to ADIF Signed-off-by: Josef 'Jeff' Sipek <jeffpc@josefsipek.net>
common: properly default to the current hlq version when unpacking Signed-off-by: Josef 'Jeff' Sipek <jeffpc@josefsipek.net>
hlog: add 'section' command to set ARRL/RAC section abbreviation Signed-off-by: Josef 'Jeff' Sipek <jeffpc@josefsipek.net>
common: add ARRL/RAC section to qso_side Signed-off-by: Josef 'Jeff' Sipek <jeffpc@josefsipek.net>
common: abort hlq packing of version incompatible fields Currently, there are no such fields. Signed-off-by: Josef 'Jeff' Sipek <jeffpc@josefsipek.net>
common: use _val for local variable in a macro Passing 'val' to this macro results in a legitimate warning: variable 'val' is uninitialized when used within its own initialization The simplest way to avoid this is to prefix the local variable with an underscore to make this scenario less likely. Signed-off-by: Josef 'Jeff' Sipek <jeffpc@josefsipek.net>
xlua: a very rudimentary K1USN SST contest script Signed-off-by: Josef 'Jeff' Sipek <jeffpc@josefsipek.net>
common: error out if hlq packing encounteres bool type with too old version The bool type was introduces in HLQ version 1. We should never see it in an older version. Signed-off-by: Josef 'Jeff' Sipek <jeffpc@josefsipek.net>
common: plumb hlq version through packing code This will be needed for additional version checks to avoid generating malformed files. Signed-off-by: Josef 'Jeff' Sipek <jeffpc@josefsipek.net>
common: error out if trying to set a HLQ item with incompatible version Signed-off-by: Josef 'Jeff' Sipek <jeffpc@josefsipek.net>
common: make qso_set_hlq_item take a HLQ version Signed-off-by: Josef 'Jeff' Sipek <jeffpc@josefsipek.net>
common: error out if hlq parsing encounters bool type prior to HLQ1 Signed-off-by: Josef 'Jeff' Sipek <jeffpc@josefsipek.net>
common: mark hlq_append_* as static Now that all the packing code is in one file, we can make these functions static. Signed-off-by: Josef 'Jeff' Sipek <jeffpc@josefsipek.net>
common: move all hlq code into qso-pack.c The split between hlq and qso-pack makes sense at a high level but results in awkward division of code. The simplest solution is to combine the two. The code can be separated again if/when we support more than just HLQ file formats. Signed-off-by: Josef 'Jeff' Sipek <jeffpc@josefsipek.net>
edit-qso: use HLQ_VERSION_USE_DEFAULT instead of -1 Signed-off-by: Josef 'Jeff' Sipek <jeffpc@josefsipek.net>
common: move HLQ_VERSION_* into headers The MIN/MAX/CUR defines are internal and so they should be in qso-impl.h. The USE_DEFAULT define should be usable by common lib consumers, so it should be in qso-pack.h. Signed-off-by: Josef 'Jeff' Sipek <jeffpc@josefsipek.net>
common: rename qso_impl.h to qso-impl.h A dash is easier to type and is marginally easier on the eyes. Eventually, all the files should get the same s/_/-/ treatment. Signed-off-by: Josef 'Jeff' Sipek <jeffpc@josefsipek.net>
common: rename qso-serde to qso-pack The code itself uses the pack/unpack terminology, so let's use it in the file names as well. Signed-off-by: Josef 'Jeff' Sipek <jeffpc@josefsipek.net>
xlua: make side_fields struct static const Signed-off-by: Josef 'Jeff' Sipek <jeffpc@josefsipek.net>
rpc: apply hamlib quirks only on buggy hamlib versions The ABI_VERSION_{MAJOR,MINOR,PATCH} defines were added only relatively recently (early 2023) but should only appear later this year in hamlib 4.6. Signed-off-by: Josef 'Jeff' Sipek <jeffpc@josefsipek.net>