Added tag v4.2.0 for changeset 240b42b99796
Bump the minor version, update history.
Update required Ruby version for Ruby 3
Update signing cert, bump rake-deveiate dependency for Ruby 3.
Adding release checksum.
Added tag v4.1.0 for changeset 803483c403dc
Bump the minor version, update history
Add support for two-argument #respond_to? to Configurability::Config
Adding release checksum.
Added tag v4.0.0 for changeset b9bc842f1a3d
Update my gem-signing cert
Bump the major version, update history.
Unhoeify and update for Ruby 2.7

- Remove tainting, which is deprecated in 2.7 and beyond.
Enable SafeYAML if it's loaded
Use rubygems naming for the deps file
Add some notes to the History
Next