dispatch: unroll mro computation to make it more palatable
test: rename test for clarity
doc: add a small bibliography
test mro, refactor next_method/call_next_method, method decorator accepts tuple as type specifier argument for multiple registration
use ambiguity check from gvr's overloading.py, remove useless test
turn back mro computation into GF parameter
use generators, cleanup & simplify a bit
[tests] diamond inheritance & next_method, ambiguous case
remove tuple around function in func table
re-add next-method support
remove unused table element
trim down a bit, add an internal signature/method cache, add a test
initial generic function/multimethods package based on David Mertz multimethods.py